I-Learn 3 Forum

Link to Course Content - Page Not Found

Good Evening All,

I have been trying to insert links to course content by using the "Insert Quicklink" tool but the link doesn't work.  After posting the link and selecting it I always get the below error:

Is anyone else experiencing this?  Is this a known issue or am I not doing it right?  I'd really like to be able to use this feature, especially when students don't complete assignments correctly.  By linking to the original course content page they can review the requirements easily and quickly. 


You need to be a member of BYU-Idaho Online Instruction Community to add comments!

Join BYU-Idaho Online Instruction Community

Email me when people reply –


  • Can you make a screencast recording so I can see what might be happening?

    • See below:

      Link to Course Content (Video)

      • Adam, I get the same results when I test a link while editing, but once the page or announcement is published, the link seems to work fine. Can you verify that?

        • Yes.  I believe that was the issue.  Thanks!

    • Here is a screencast of what I am seeing in my course with that issue - http://screencast-o-matic.com/watch/cbV6eOQgX7 ;

      • Hi Arnold, I can't view your screencast. It looks like Ning may have truncated the link. You can create the link manually? I'd like to see if you are doing the same thing Adam is. 

        • I had the same problem, but deleted the space at the end (right after the 7), and was able to view the screencast.

          • Thanks DaNae. Arnold, I've seen this a few times now, but only when I'm editing a page, email, announcement, etc. It seems that once the item is published, we don't see this problem. 

      • Have you sent an email to yourself and tried to open the link after the email was sent?  I just did what you did (right clicked before sending the email), and got the same error.  But, then I sent the email to myself and clicked the link and it took me to the correct page, I did not get the "error" message.  So maybe there is just something weird happening that makes the link not active/live until the email is actually sent.  It also worked in the announcement I posted.

        Maybe you could try emailing yourself with a Quick Link and seeing if it is the same for you in your course (click the link from the email you send yourself and see if it opens).  Hopefully that will work for you!

This reply was deleted.

Can't find an answer you are looking for? Check out these additional I-Learn helps here: www.byui.edu/ilearn3